Skip navigation

For the first time this year, on Saturday afternoon, Tucson hit 100 degrees Fahrenheit.

What started off as a relatively warm March/April, slackened to a fabulous April/May, with temperatures rarely exceeding 90 F.

But on the 30th of May, well, there we went. All coolers are up and running, of course, but I had to make a run on Sunday over to one of our places. It seems that a thermostat had given up the ghost, in a rather spectacular fashion.

DSC03229

DSC03231

Thankfully, the tenant was home and demonstrated that she has some wits about her, shutting off the breaker to the thing before it went full conflag. Within two hours of receiving her distress call, I had a new thermostat installed.

The exact same model…

Advertisements

3 Comments

  1. And the same wires ? HOLY COW !

    • Ayup, same wires. It appeared as though the problem was on the Chinese circuit board, not the house wiring.

      Dial (the company that sells these things), has a lot of splainin’ to do.

        • Leana
        • Posted June 2, 2015 at 10:26 am
        • Permalink

        LOL- nice ! 🙂


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: